Log In | Sign Up Now! | Help & Support | Print Print This Page
   Day Past Ovulation 56789101112131415    
Start a New Topic

Trying to Conceive Discussion Forum

Recent Activity Forum Categories   Hide Signatures

1st round Clomid, 15DPO, light brown discharge

Category: Two Week Wait - Symptoms
Posted by JHRBlondie » Apr. 21, 2011 3:28pm

Hi girls, so i need some help. I am currently on my first round of Clomid, and 15DPO. I could have sworn I was pregnant, as I was having all these symptoms. Possible implantation cramping 8DPO, weird pressure in my vaginal and lower back, really tender nipples, headaches, etc. But yesterday, my AF was due, and I started passing light brown discharge and tissue. Nothing major, but enough to see when I wipe. Normally this indicates my AF is fastly approaching. But today, almost 2 full days of this discharge, and I have no other signs of AF. No cramps or bloating. Im starting to wonder if this is just a side effect of the Clomid, and that Ill get my full period soon. Or if I could still be pregnant. Ive heard some women pass brown clots or discharge in early pregnancy to get rid of old blood. Has anyone had a similar situation on Clomid and was actually pregnant??? Or am I doomed to start yet again another cycle. Thanks for listening :)

Report

JHRBlondie
Posts: 38
Reply by NSONG711 » Apr. 22, 2011 3:45pm

I HAD TAKEN CLOMID 50 MG DAYS 3 -7. I AM ONLY 8 DPIUI. I HAVE HAD SOME LIGHT BROWN CM ONLY WHEN I WOULD WIPE A FEW TIMES. NOW IT IS JUST A MILKY COLOR. I SEEMED TO HAVE MORE SYMPTOMS UP UNTIL DAY 6 AND NOT SO MUCH NOW. HAVE YOU TESTED YET?

Report

NSONG711
Posts: 7

Reply by JHRBlondie » Apr. 22, 2011 4:56pm

Well this wasnt my month. Got the dredded period today!! I guess it was just my monthly cycle taking its time. Your discharge sounds like it could be implantation spotting. Good luck, and Im on to round 2 of the Clomid :)

Report

JHRBlondie
Posts: 38

Reply by MissCommunication » Aug. 8, 2012 9:49am

I had a TR done 14 June 2012. I was told I don't ovulate on my own and would be placed on Clomid. I took it days 3-7 (1st round). I had cramping about a week later but knew it was from the Clomid doing it's job. I had sore BB's for about 2 weeks but they have since stopped hurting. I had brown spotting 8, 9 & 10 DPO. Thought AF was on the way. I am now 15 DPO and still no sign of AF. I haven't tested in a couple days, as I thought AF would finally arrive. My average cycle days are 27 (I've had some as long as 30 and some as short as 26). My longest luteal phase is 15 days so I should expect AF today. I have no cramps to indicate it should arrive any time soon. Yesterday I was slightly moody & had a headache but that was it. I'm picking up a test today but doubt it will be positive. I'm just certain my AF is late due to the Clomid

Report